
Welcome, as you enter the Zoom please type in the chat:
Your Name & Your School

Note: This presentation will be recorded so team 
members not in attendance may be able to rewatch 
later



Webinar Overview

■ RockSim Overview
■ Assumed you have a basic knowledge of RockSim

■ RockSim Resources
■ To give you a basic knowledge of RockSim

■ RockSim Rocket Files
■ How to get a RockSim file

■ RockSim Load / Verify / Recovery / Mass Object / Motor / Flight data
■ Performance Requirements

■ Common Errors



RockSim Overview

■ From RockSim

■ First Nations Launch requires all teams to acquire and use RockSim for 
design, component and motor selection prior to parts procurements.
■ For consistency, all teams must use the same simulation program – RockSim.

Presenter Notes
Presentation Notes
What is it? Why do we use it? Required software.



RockSim Resources

■ FNL RockSim Resources
■ Advisor Handbook – Appendix D-3

■ Goals of Simulations / Simulation Parameters / Procurement
■ Additional Design Files (that are not in the RockSim Library)
■ Additional Motor Files (that are not in the RockSim Library)

■ Rocket Instructional Videos – FNL RockSim
■ Download / Install / Temp License (Award Number) / School License
■ User Interface Overview
■ RockSim Rocket Database / Motor Database
■ Parameters

https://spacegrant.carthage.edu/first-nations-launch/rocket-instructional-videoswebinars/

Presenter Notes
Presentation Notes
Existing FNL RockSim Resources.
For the sake of time - We will not cover most of these topics in this Webinar

https://spacegrant.carthage.edu/first-nations-launch/rocket-instructional-videoswebinars/


RockSim Resources

■ Apogee Components Website
■ RockSim Overview – Various Topics

■ https://www.apogeerockets.com/RockSim/RockSim_Information

■ RockSim Video Tutorials – 35 Topics
■ https://www.apogeerockets.com/RockSim/RockSim_Video_Tutorials

■ Newsletter Articles – Over 100 Topics 
■ https://www.apogeerockets.com/Peak-of-Flight?pof_list=topics&m=education&#RockSim

■ RockSim Program Guide
■ https://www.apogeerockets.com/downloads/PDFs/Rocksim.pdf

https://www.apogeerockets.com/RockSim/RockSim_Information
https://www.apogeerockets.com/RockSim/RockSim_Video_Tutorials
https://www.apogeerockets.com/Peak-of-Flight?pof_list=topics&m=education&#RockSim
https://www.apogeerockets.com/downloads/PDFs/Rocksim.pdf


RockSim Resources



RockSim Rocket File



RockSim Rocket Files

■ There are 2 methods to beginning your simulations;
■ (Preferred) Download the basic rocket file, of the kit you selected

■ Researching kits - most manufacturers provide a basic RockSim file
■ If no file, you can search the internet for a basic RockSim file

■ https://www.rocketreviews.com/rocksim-library.html
■ Note: this file should be inspected to verify it reflects what you expect
■ Note: this file will likely be very basic, and need improvements

■ Build the kit components from scratch in RockSim
■ This works if you have the components on-hand and can measure dimensions

https://www.rocketreviews.com/rocksim-library.html


RockSim Rocket Files

Example of a vendor website – link 
for the RockSim file highlighted



RockSim Rocket Files

https://www.rocketreviews.com/rocksim-library.html

Example of RockSim User Library –
link for the RockSim file highlighted

https://www.rocketreviews.com/rocksim-library.html


Running Simulations



RockSim Rockets – Load File

■ You have your .rkt file -> Open RockSim -> Load the File



RockSim Rockets – Load File

■ You have your .rkt file -> Open RockSim -> Load the File

File -> Open -> Opens RockSim Design Database
(or navigate to where you saved your .rkt file)

Presenter Notes
Presentation Notes
The RockSim Design Database has a large number of rocket files, but may not have all existing rockets.



RockSim Rockets – Load File

■ You have your .rkt file -> Open RockSim -> Load the File

Presenter Notes
Presentation Notes
Basic kit – missing a lot of details that need to be added (will see all the components at the end of this Webinar).
Take note of the highlighted attributes – you should be using the Barrowman equations for CP, and ensure Single Stage / Nosecone Base Diameter are selected.



RockSim Rockets - Verify

■ Verify the loaded Rocket (file) accurately represents what you expect

Sustainer / Main Parachute

Coupler / Avionics Bay

Switch Band

Booster / Drogue Parachute

Nosecone Shoulder Centering Rings

Presenter Notes
Presentation Notes
Note: Missing some parts, will add later – but this should be your starting point, every rocket should have these components in this order!



RockSim Rockets - Verify

■ Verify the loaded Rocket (file) accurately represents what you expect

Note: Sequential Order
Note: Naming Convention

Note: Grouping Parts

Presenter Notes
Presentation Notes
The component tree – be sure you understand what all the parts are (this is similar to CAD modelling)



RockSim Rockets - Recovery

■ You will need to replace the existing Parachutes in the model
■ Your Parachute selections will need to satisfy the descent Requirements
■ You need two Parachutes (a Drogue and a Main) – example shows Main only



RockSim Rockets - Recovery

■ You will need to replace the existing Parachutes in the model
■ Your Parachute selections will need to satisfy the descent Requirements

Rate 
Exceeds 
Requirements

So, select a larger parachute – use the RockSim Database

Presenter Notes
Presentation Notes
Goal is to select a Main parachute such that the descent rate matches the range in the Requirements.
Typically, do not input values in the selection box, but select a parachute from the Database
Note: not all parachutes on the market are in the Database – select something similar to get correct values



RockSim Rockets - Recovery

■ You will need to replace the existing Parachutes in the model
■ Your Parachute selections will need to satisfy the descent Requirements

Note: The rectangle represents the volume that your parachute selection is expected to occupy. 
Ensure your parachute will fit in the airframe! Check the specs!

Note: The position of the parachutes are aft in their respective tubes– this is where they will sit when 
the rocket is vertical – this affects the CG, so position accordingly!



RockSim Rockets – Challenge ‘Mass Object’

■ You will need to add a Mass Object for the Challenge Electronics

Presenter Notes
Presentation Notes
We will add some mass to represent the Challenge Microcontroller and Sensor – We will position the electronics in the Avionics Bay 
Highlight the ‘owning’ part – “Add New Component – Mass Object”
Note the owning part is highlighted in the image as well.



RockSim Rockets – Challenge ‘Mass Object’

■ You will need to add a Mass Object for the Challenge Electronics

Manually input the mass / location – name 
accordingly. Mind the units.

Database box may pop up – close this, not needed now.

Presenter Notes
Presentation Notes
Estimate the initial masses, based on vendor (online) data;
Weigh (verify) the masses when your components arrive, and update.



RockSim Rockets – Challenge ‘Mass Object’

■ You will need to add a Mass Object for the Challenge Electronics

Note the part is added as a ‘M’ object, at the location shown.

You will need to repeat this for all your Challenge components.

Presenter Notes
Presentation Notes
Repeat for all Challenge objects to include their masses and indicate their locations in the rocket.



RockSim Rockets – General ‘Mass Object’

■ You will also need to add a Mass Object for the General Components.

Add New Component -> Mass 
Object -> Database dialog box is 
convenient for adding mass of 
standard items – altimeters, 
eyebolts, threaded rods, etc.

You will need to add all these 
components as you eventually 
make all component selections.

Presenter Notes
Presentation Notes
Also add all General Mass Objects, to represent all internal components (hardware, electronics).



RockSim Rockets – Prepare For Launch ‘Motor’

■ You will Prepare for Launch -> Select / Load a Motor

Presenter Notes
Presentation Notes
Select Simulation -> Prepare for Launch
Opens the RockSim Simulation Properties Dialog Box -> go to Engine Selection Tab -> select Choose Engine



RockSim Rockets – Prepare For Launch ‘Motor’

■ You will need to select / load a Motor
■ Handbook Appendix A-1 has Challenge Motors
■ This year they are in the RockSim Database
■ If Motor not found in Database

■ You can import a motor (see Resources)

You can find complete motor data at – https://www.thrustcurve.org/

Presenter Notes
Presentation Notes
Note: Your motor mount tube size should match the size of the motor (54mm for MARS 2025 Challenge) – if your kit comes with something different, please contact the vendor and ask for the correct size.
Many of the other parameters are not a concern (ejection delay is not needed in sim but is needed in the real flight – plugged is sufficient, as will use flight event apogee to deploy parachute in sim).
Ignition delay is irrelevant (set to null). Engine overhand is irrelevant (set to null).

https://www.thrustcurve.org/


RockSim Rockets – Launch

■ Run the simulations!
■ Multiple ways to run

Presenter Notes
Presentation Notes
Launch!
(Don’t worry we will iterate, just need to see what the performance parameters are currently).



RockSim Rockets – Flight Data Requirements

■ Examine simulation Data – ensure you meet performance Requirements!
■ Max Altitude
■ Static Margin
■ Rail Exit Velocity
■ Thrust to Weight Ratio

■ Descent Rate - Main
■ Descent Rate - Drogue

■ Other FlySheet Data 

These columns are selectable to about 20 parameters



RockSim Rockets – Flight Data

■ Flight Profile Data
■ Visual of the simulated flight profile
■ Various data at all points in time of the flight
■ Profile can help ensure parachutes are 

configured (deploy) properly 
■ Profile can help ensure drift is within 

Requirements



RockSim Rockets – Flight Data

■ Plotting Data
■ Useful in Reports
■ Plot any parameter versus time

■ Thrust curve for example
■ Plot single or multiple parameters
■ Can zoom axis for more detail



Common Errors



RockSim Rockets – Common Errors

■ Ensure Vehicle Mass Override is OFF (and do not use)

■ Ensure Cd Override is ON (and do not use)

■ Ensure all Drag is accounted for (Rail Buttons, Surface Finish)

■ Ensure Parachutes are configured to deploy properly

■ Ensure Launch Guide length is configured properly

■ Ensure all Mass Objects are accounted for



RockSim Rockets – Common Errors

■ Ensure Vehicle Mass Override is OFF (and do not use)
■ If adding components (mass) does not change altitude – check this setting

BOX SHOULD BE UNCHECKED

Presenter Notes
Presentation Notes
1) RockSim calculates the mass of each component based on its 1) dimensions (volume) and 2) material density (material selection)
2) RockSim then calculates the mass (and CG) of the entire rocket by summing weighted average of all components



RockSim Rockets – Common Errors

■ Ensure Cd Override is ON (and do not change)
■ If changing (adding) drag does not change altitude, check this setting

BOX SHOULD BE CHECKED

Presenter Notes
Presentation Notes
RockSim calculates the Co-efficient of Drag of the entire rocket, based on 1) the frontal nosecone area and protuberances (form drag or pressure drag) and 2) the surface finish (surface drag or viscous drag)
Unless you have performed wind tunnel tests, there is no way you know the Co-efficient of Drag for individual components or your rocket.



RockSim Rockets – Common Errors

■ Ensure all Drag is accounted for - Rail Buttons
■ If making drag adjustments does not change altitude, see Cd Override slide

Any surface protuberance should be modeled

Presenter Notes
Presentation Notes
As previously, you want to ensure you account for all drag in simulation (to obtain an accurate apogee).
RockSim V10 you need to create a ‘mock’ rail button, by using Add New Component -> Fins
Change the highlighted parameters to represent a rail button on the side of the rocket.



RockSim Rockets – Common Errors

■ Ensure all Drag is accounted for - Surface Finish
■ If making drag adjustments does not change altitude, see Cd Override slide

Select the finish that most 
appropriately represents your rocket.

Adjust the finish to see the effects on 
altitude – all body tubes, fins, nosecone.



RockSim Rockets – Common Errors

■ Ensure Parachutes are configured to deploy properly
■ Improperly configured, they deploy too early (false apogee) or not at all

Drogue Parachute - deploy at Apogee
Main Parachute - deploy at Altitude
(Pick your altitude to meet requirements)

Presenter Notes
Presentation Notes
Select Simulation -> Prepare for Launch
Opens RockSim Simulation Properties Dialog Box -> select Flight Events tab -> Ensure 2 parachutes -> Configure as noted.



RockSim Rockets – Common Errors

■ Ensure Launch Guide length is configured properly
■ If your rail exit velocity (launch guide departure) is too low, check this setting

Typically, 72-inch rail
Can be 120-inch rail
(Never 32-inch rail which is default)

Presenter Notes
Presentation Notes
Select Simulation -> Prepare for Launch
Opens RockSim Simulation Properties Dialog Box -> select Starting State tab -> Ensure Launch Guide Length is: 72-inch.



RockSim Rockets – Common Errors

■ Ensure all Mass Objects are accounted for by CDR
■ If add mass after motor selection, your apogee will change / not meet target altitude
■ Note all individual components (bolts, batteries etc.) are accounted for in simulation

Presenter Notes
Presentation Notes
CDR Rocket Details – accounts for as many components as possible



Questions?

39
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